Search

User Manual

Getting Started


Modules and Platform


Appendix


Tutorials & Helpful Tricks


Glossary


Strategic Partner Links

Sepasoft - MES Modules
Cirrus Link - MQTT Modules

Resources

Inductive University
Ignition Demo Project
Knowledge Base Articles
Forum
IA Support
SDK Documentation
SDK Examples

All Manual Versions

Ignition 8
Ignition 7.9
Ignition 7.8

Deprecated Pages

Skip to end of metadata
Go to start of metadata



Vision Designer Workspace

When looking at a Vision specific element in the Designer, such as a window or template, the Designer is organized with some panels that are specific to the Vision Designer Interface, such as the Property Editor and Component Palette. Other elements of the workspace that are shared between spaces are discussed in the General Designer Interface.




On this page ...


IULocgo


Using Designer User Interface

 

Component Palette

The Vision module comes with a host of useful components out of the box, such as buttons, text areas, dropdowns, charts, and many more, many of which are specialized for industrial controls use.  The Component Palette is located on the right side of the Designer workspace. The basic workflow is to drag a component from the component palette and drop it into a container on a window. From there, you can use the mouse to drag and resize the component into the correct position. While the component is selected, you can use the Property Editor panel to alter the component's properties, which changes the component's appearance and behavior.


The Property Editor

The Property Editor is a dockable panel that appears in the Designer's central workspace, usually in the lower left corner. It displays the properties of the selected component. If more than one component is selected, it will show all properties that the current selection set have in common. Hovering your mouse over a property will display a tooltip that gives a description of the property, as well as its data type and scripting name. Alternately, you can click on the Show/Hide Description Area icon to bring up the description area which displays the same information for the currently selected property.

You can also change how the properties are sorted in the property editor. By default, they are sorted with the Categorized  icon, with similar components grouped under different categorical headers. However, they can also be sorted in alphabetical order by clicking on the Alphabetic  icon.

Filters

It is common for components to have many properties, so by default the Property Editor only shows the Basic properties. These are the properties that you'll most commonly want to set or bind for a given component. However, the property filter can be changed to show different sets of properties. The designer will remember your selection for future sessions. 

  • Basic: The Name property and any very commonly used properties. Most components only show two to four properties in Basic.
  • Standard: Most of the common properties that a designer would want to use. Few or none of the Expert properties are in the Standard list.
  • Expert: The properties that are most commonly used with more advanced features of the component. Few or none of the Standard properties are in the Expert list.
  • All: All properties

Most users find it best to set the property filter to All, so they can see all of the properties available to them at all times.

The Binding Button

To the right of most properties is the Binding  icon. Click this icon to modify the property binding that is driving that property. You can only use this button when the window workspace is not in Preview mode. Some properties cannot be bound because their datatype is not supported by the binding system. You can still use scripting to affect these properties.

Status Indication

The name of a property in the Property Editor conveys important information about that property:

  • blue name indicates that the property is a custom property
  • A bold name with a Link  icon next to the property indicates that the property is bound using a property binding
  • bold name with a Color Palette  icon indicates that the property is being affected by the component styles settings.
  •  red bold name with a Warning  icon indicates that the property is double-bound. This means that two things, a property binding and the styles settings are both trying to drive the property value. This will result in errors as the two systems fight each other to write to the property.

Dropdown Lists in Properties

Some of the properties you will encounter on components will have a dropdown list instead of a field to type into. The property description will say it is an integer value, and in most of these cases you can still create a binding on that property. These dropdown lists are an enumeration, meaning each element in the dropdown has an integer value. In all cases, the first value in the list is 0, the second is 1, the third is 2, and so on. You can use this knowledge to create a dropdown list on-screen for your operators that matches the list. In this case, you would just bind this property to the Selected Value of the dropdown.

Common Properties

Every component has properties arranged into categories based on what it has available (i.e., Common, Behavior, Data, Appearance, Layout, etc.). Each component has a different list of properties to effect how it behaves, but every component has the Common group of properties located at the top of the list. These Common properties will behave the same for all components. Here's a list for each Common property and when it might be used.

FunctionDescription
NameThe name of the component. This string is used to identify your components in the Project Browser. This is especially important for Bindings and Scripting. Binding is allowed on this property, but it is recommended to never bind this property. Binding it can break your scripts, bindings, and cause errors.
EnabledThis Boolean controls whether a component can be interacted with. Most commonly used with data entry components to allow the user to see the value, but not change it.
VisibleThis Boolean controls whether the component is shown on the window. You can bind this property to show/hide the component based on any logic you want (i.e., security, process step, etc.).
BorderThe border that surrounds the component. There is a dropdown to select from a list of common borders, and a button to the right to manually edit a border from several different options with a second tab that shows Titled Borders. When binding this property, note that this is a complex data type. It is a Java Border data type, not a string or an enumeration. The common ways to make this property dynamic are to bind it with an Expression binding type or to set it through a script, but using the Expression binding is preferred. If you are using an Expression binding, you must use the toBorder() expression function to return the correct data type. If you are using a script, you need to make sure you use the Java Border data type. See the Java documentation for more information on setting a border through scripting.
Mouseover TextThe text that is displayed when a user moves the mouse over the component. This string is commonly used to provide your operators more information about an object (i.e., showing the PLC address of an on-screen value, or telling the operator exactly what will happen when a button is pressed). HTML is allowed in this property.
Cursor

The mouse pointer image to use when the operator moves the mouse over the component. This int property corresponds to one of the options in the list. Selecting 'default' means the operating system decides what pointer to use.

 Possible Cursor Values
ValueCursor
0Default
1Crosshair
2Text
3Wait
4SW Resize
5SE Resize
6NW Resize
7NE Resize
8N Resize
9S Resize
10W Resize
11E Resize
12Hand
13Move


Vision Menubar

There is a menubar at the top of the Designer Workspace that provides functionality that you can interact with when working in the Vision space. Each menu has a host of functions as it relates to that menu. The other menus that are shared between spaces are discussed in the General Designer Interface.

Edit Menu

The Edit Menu is also similar to other applications edit menus in that it provides much of the basic copy/paste functionality.


FunctionDescription
Undo and RedoCan be used to revert to the previous state, essentially removing the last change, or redoing it again after having been removed. This has a large queue that can be traversed, but does not include every change (i.e., Tag edits cannot be undone).
Cut/Copy/Paste/DuplicateThese functions much the same as they do everywhere else. Most things in the Designer can be copied and pasted elsewhere, from individual components on the window to entire folders of windows. The difference is that when using Paste with an object on a window, it will instead create a paste action, and allow you to move the mouse and select where you want to paste it, clicking the mouse to confirm. Cancel Paste will cancel the paste action, while paste immediate will bypass the paste action, and instead immediately paste the object from where it was cut or copied from.
Fine/ReplaceBrings up the Find and Replace interface to allow you to find specific objects within the project. See also: Find and Replace
Select All

Selects All siblings in the same container as the currently selected component.

Select Same TypeSelects all components of the same type in the same container as the currently selected component.
Select Same Type in WindowSelects all components of the same type as the currently selected component, regardless of what container they are in.
Group RenameRenames a group of components to a prefix with a number afterwords. For example, if your prefix is Button, it will rename all selected components Button (1), incrementing the number each component.
DeleteDeletes the currently selected component. This can also be done using the delete key.


View Menu

The View Menu allows you to manipulate how various objects look or act in the Designer.


FunctionDescription
Emulate TouchscreenSimulates Touchscreen mode in the Designer to be able to test it without having to open a client.
Disable OverlaysDisables the red or gray overlays on components because of a bad Tag or binding, but only in this Designer session.
Reset PanelsResets panels (Project Browser, Tag Browser, etc.) to the default panel configuration.
PanelsAllows you to enable or disable certain panels within the Designer.
ToolbarsAllows you to enable or disable certain toolbars within the Designer.
Welcome ScreenTakes you to the welcome screen in the Designer, or reopen it if it had been closed.
Grid SizeAllows you to select a grid size of 5 or 10.
Show GridToggles the grid on and off.
Snap to GridChanges click-and-drag behavior to snap components to grid lines. This works even when Show Grid is off.
Show GuidesShows any guide lines.
Snap to GuidesChanges click-and-drag behavior to snap components to any created guidelines.
New GuideAdds a guide line to the current window.
SpotlightsPuts a highlighted border around components that have the selected spotlight. Bound objects will get a green highlight, objects with scripting will get a blue highlight, and invisible objects will get a pink highlight. If a component has multiple highlights, and both are enabled, it will alternate the colors throughout the highlight.
DependenciesShows the binding dependencies (as arrows) based on the selected component or components. Show Supporters will show all components that the currently selected component is bound to, Show Dependents will show all components that are bound to the currently selected component, and Show All will show all of the bindings, regardless of the selected components.


Project Menu

The Project Menu is where many project specific settings can be changed.


FunctionDescription
Designer CommsThe Comm settings allow you to select the level of communication the Designer can have with the Gateway. By default, this is set to Comm Read-Only, which will make any information coming from the Gateway read only, but this can be changed to Comm Off which will prevent Gateway communication, or Comm Read/Write, which will allow both read and write communications between the Gateway. The default that the Designer opens at can be changed in the Project Properties. See also: Communication Modes
PropertiesOpens up the Project Properties window, allowing project settings to be changed. See also: Project Properties
Event ScriptsOpens up the appropriate event script window, either client or Gateway. These can also be accessed from the Project Browser. See also: Client Event Scripts and Gateway Event Scripts.
Preview ModePuts the Designer into Preview Mode, allowing you to interact with it like a client. See also: Previewing the Project
Preview LanguageDetermines the language that the Designer will revert to when in Preview Mode. See also Localization in Vision


Component Menu

The Component Menu offers many of the same selections for the selected component that right clicking on that component would contain.


FunctionDescription
Group

Only available when multiple components are selected. Grouping will place the currently selected components into a group. Ungroup will remove the grouping. See also: Working with Components

UngroupOnly available when a group is selected. This option removes the group (and any custom properties that are on the group) and places all items from that group into the object the group was in.
Convert to Container

Only available when a group is selected. Converts the selected group to a container. See also: Container

LockLocks or unlocks the selected component's size and position.
LayoutSet layout constraints for the selected component.
Size and PositionChange the size and position of the currently selected component.
CustomizersAllows you to select any of the available customizers for the currently selected component.
ScriptingBrings up the scripting window for the currently selected component.
SecurityOpens up the Security Settings Panel, allowing security to be placed on the selected components.
TranslationsBrings up the Translatable Terms Panel, showing any translations for the selected component.


Alignment Menu

The Alignment Menu options allow you to adjust the alignment of components relative to other components.


FunctionDescription
MoveThe move commands move a component on its z axis, as in front of or behind other components. It can be moved to the far back or front, or done in single steps.
AlignThe align commands move all selected components to the edge of the furthest component. So if Align Left was selected, it would move all components to the leftmost component's edge.
Align CentersAligns all of the selected components either vertically or horizontally on their centers.
Align as RowAligns all of the components on their centers as a row or stack, and will add padding between them that you can select. Normalizing them will change the size of all of the components to the first selected component.
Center

Centers the currently selected components relative to their parents either vertically or horizontally.


Shape Menu

The Shape Menu allows for manipulation of shape or path objects.


FunctionDescription
RotateRotates the currently selected shape 90 degrees either right or left.
MirrorFlips the component either vertically or hoizontally.
UnionAlters the first shape to be the combination of all selected shapes.
DifferenceAlters the first selected shapes by removing the last selected shape from them.
IntersectionAlters the first shape to become a new shape consiting of the area they share.
ExclusionAlters the first shape to become a new shape consiting of the area they do not share.
DivisionCuts the first shape into multiple shapes along the borders of other shapes.
To PathConverts a shape to a simple path object.
StrokeConverts the selected shape into a new shape defined by its stroke.



 

  • No labels