Search

User Manual

Getting Started


Modules and Platform


Appendix


Tutorials & Helpful Tricks


Glossary


Strategic Partner Links

Sepasoft - MES Modules
Cirrus Link - MQTT Modules

Resources

Inductive University
Ignition Demo Project
Knowledge Base Articles
Forum
IA Support
SDK Documentation
SDK Examples

All Manual Versions

Ignition 8
Ignition 7.9
Ignition 7.8

Deprecated Pages

Skip to end of metadata
Go to start of metadata


Designer Spaces

The Designer has a lot of panels and menus that allow you to build out a project tailored to your needs. However, while some of these like the File Menu are shared throughout the Designer, some of the panels and menu options are specific to certain objects and will typically only be displayed when an object of that type is selected. For example, when editing a Vision Window, the Designer has the Property Editor and Component Palette panels, but when editing an Alarm Pipeline, the Pipeline Blocks and Pipeline Block Editor panels are displayed instead. This creates different Designer Spaces that are used for different areas of a project.

There are many dockable and draggable panels that surround the workspace, as well as the familiar menu bars and toolbars. The dockable panels can be rearranged as you wish and will snap into place as you move them around the screen. Each workspace remembers its layout, which is the docking arrangement of the panels around it.

Docking System

The Designer's docking system provides a very flexible user interface allowing you to customize the layout as you wish. To rearrange the dockable panels, simply drag on their title bars. As you drag the panel, it will try to snap into place and show you a highlighted border. Use the highlighted border that appears to gauge where the panel will be moved to. Hold the CTRL key as you drag these panels to keep them from snapping into place. You can also drag these panels outside of the Designer or onto a second monitor. 

Dockable panels can be in one of four modes:

On this page ...

  1. Docked - The panel is visible, and located somewhere around the perimeter of the workspace. If two panels are docked in the same location, a tab strip will appear to switch between the two panels.
  2. Floating - A panel can be dragged outside of the workspace perimeter to be floated. The panel can now be positioned anywhere on your desktop.
  3. Pinned - Pinning a panel makes it minimize to one of the four sides of the Designer, represented by a small tab. Hover over the tab to use the panel.
  4. Hidden - A hidden panel is not shown. You can open it again by selecting it in the View > Panels menu.

Toolbars can also be rearranged and floated to your liking. Simply drag on the "textured" left edge of the toolbar. If you re-arranged your panels into a layout that you don't like, you can quickly revert back to the default by selecting the View > Reset Panels option from the menu bar.

Expert Tip

Your docking preferences are stored under %USER_HOME%/.ignition/*.layout. If you really want to reset your preferences, remove these files and restart the Designer.


Project Browser

The Project Browser panel allows you to view the different Designer Spaces, and their component hierarchies at a glance. By clicking Project Properties  icon you can view or change many of the properties settings in your project. You can expand the folders and navigate down through each folder to see elements of your project such as windows, views, containers, and components. The Project Browser shows the entire tree structure from the project level folder down to the component level. You can navigate within your project in two ways, by selecting nodes in the Project Browser tree or directly clicking on an element like a component in the project workspace. Regardless of how you select an element, properties for that element are displayed in the Property Editor. 

Project Resources

All projects have resources, such as Vision Windows, Vision Templates, Perspective Views, project scripts, reports, and named queries. Project resources can be inherited from one project to another. For more information, see Project Inheritance.

Naming Conventions

Project resource names cannot be blank. They must start with a letter, a numeral, or an underscore. The following characters are reserved and cannot be used in names for project resources.

 < (less than)
 > (greater than)
 : (colon)
 " (double quote)
 / (forward slash)
 \ (backslash)
 | (vertical bar or pipe)
 ? (question mark)
 * (asterisk)

In addition,the following names cannot be used as project resource names:

CON, PRN, AUX, and NUL
COM1, COM2, COM3, COM4, COM5, COM6, COM7, COM8, and COM9
LPT1, LPT2, LPT3, LPT4, LPT5, LPT6, LPT7, LPT8, and LPT9

Right-Click Menu

The Project Browser has basic functionality much the same as many applications that run on your PC. Functions can change depending on the type of project resource you are currently editing. When you right click on a project resource, several options are available: 

FunctionDescription
RenameChange the name of the current selection to a new name.
CutCuts the current selection into the clipboard.
CopyCopies the current selection into the clipboard.
Copy PathCopies the path of the current selection into the clipboard.
PastePastes the contents in the clipboard to the selected content.
DeleteDeletes the current selection.
ProtectProtects the Project Resource. For more information, see Protecting Project Resources.


Tag Browser

The Tag Browser panel, located on the left side of the Designer workspace under the Project Browser, allows you to browse Tags in the Designer and OPC servers. Tags an be created, edited, displayed, exported, and imported directly from the Tag Browser. See Understanding Tags for more detailed information.



Menubar

This section addresses only the functionality that the Designer menubar shares between both the Perspective and Vision modules.

For information on the menubar tabs unique to the Vision module, see Vision Designer Interface

For information on the menubar tabs unique to the Perspective module, see Perspective Designer Interface.

File Menu

The File Menu contains most of your basic options related to saving, similar to many other software applications on your PC. 

 Function Description
NewThe New menu option allows you to create a new Object. That Object could be a new window, a new template, or even a new project. It can vary depending on what modules you have installed, also providing the ability to make new transaction groups, reports, Sequential Function Charts, and more.
OpenAllows you to Open a previously created project.
SaveSaves project changes on the Gateway, but are not pushed out to the client.
Save AsSaves the current project as a new project.
Update ProjectMerges any changes from the Gateway to the project, if for example there were multiple people working on the same project.
ImportAllows you to import or export specific resources into or out of the project such as Tags, scripts, and templates, to name a few.
ExportExports globally scoped resources, such as Alarm Pipelines.


Project Menu

Communication between the Designer and the Gateway is controlled from the Project Menu. The Designer offers three data communication modes for your projects: Comm OffComm Read-Only, or Comm Read/Write. Comm Read-Only is the default mode which does not allow writing from the Designer to Tag or Database sources.


IULocgo


About Communication Modes

  • Comm Off
    In this mode all database query traffic and Tag subscriptions and writes are blocked.
    Experts often use the Comm Off mode while designing a window to temporarily shut off data flow so that they can manipulate component's bound properties without the values being overwritten by the data bindings. This is useful to set the values that they want to serialize into the window. This can be important for windows with large datasets, clearing the datasets before saving the window can significantly reduce the size of the window, thus improving performance.
    Note: This setting does not affect the execution of a project's Transaction Groups because Transaction Groups execute on the Gateway, not in the Designer.

  • Comm Read-Only (default)
    Tag subscriptions and SELECT queries work, but Tag writes and UPDATE/INSERT/DELETE queries are blocked.
    The Designer starts up in Comm Read-Only mode as a safety mechanism so that you don't inadvertently write to a Tag as you are designing. You can customize the Designer's startup mode, see the Designer/General Properties section.

  • Comm Read/Write
    All data is passed through to the Gateway. The mode can be switched at any time via the tri-state toggle selection in the main toolbar, or the radio buttons in the Project menu.
    A common beginner mistake is to forget to switch the mode to Comm Read/Write when attempting to test a window's functionality in Preview mode.

To Set or Change the Communication Mode

There are three ways to set or change the comm mode in the Designer:

  • Using the Project menu.
  • The buttons located on the Main Toolbar.
  • Using the Project Properties window.

Setting the Comm Mode from the Project Menu

On the Designer toolbar, go to the Project menu and choose: Comm OffComm Read-Only, or Comm Read/Write.

Setting the Comm Mode from the Main Toolbar

If the Main Toolbar is enabled, go to Project, and you'll see a corresponding button for each Comm Mode. The currently selected Comm Mode will have its button highlighted in gray.



Using the Project Properties Window

This will set the default Comm Mode that the Designer starts up in for the current project.

  1. In the Designer, either double-click on the Project > Properties node in Project Browser, or click on the Project > Properties command on the top menu.
    The Project Properties window is displayed.

  2. Go to Project > Designer.
  3. Under Startup Options, for the Initial Gateway Comm Mode, choose from the dropdown Comm OffComm Ready-only, or Comm Read/Write.

    These property settings are saved on a per-project basis.



Communication Error Message

If a user is attempting to write to a project in the Designer or from a Client, and the Comm Mode is not enabled for Read/Write, a dialog box will popup stating the Designer is not in Read/Write Mode. 



If your Tag is not being written too, there are a couple places to check:

  • From Main Toolbar go to Project, and make sure the Comm Mode is set to Read/Write.
  • If Comm Read/Write is checked, you may have a Client Event Script enabled that could be preventing you from writing to a project or a Tag, as shown in the error message example below. You may need to edit your Client Event Script.


Previewing the Project

Many times, it is useful to test the components on the screen to ensure that certain bindings or scripts are working the way that was intended. The Designer can go into Preview Mode that will allow you to interact with the currently opened window as though you were working in a client. This means that instead of clicking between components and seeing their properties, you will be able to interact directly with the components such as clicking on a button to execute its script, or entering a value into a text field to update a Tag value.



IULocgo


Previewing the Project

Preview Mode

The window workspace operates in two distinct modes: Design Mode and Preview Mode. There are three different ways you can switch between Design and Preview Mode:

  • One of the easiest ways is from the Main Toolbar using the Preview  icon or the Design  icon to switch between modes.



  • From the Main Toolbar using the Project > Preview Mode menu item. 
  • Using the F5 key to toggle between the two modes.

In Design Mode, your mouse is used to manipulate components in a window. You can select, drag, and resize them. You can alter data bindings and event script configuration. Data bindings are active in Design mode, but event handlers are not.

In Preview Mode, you are interacting with a "live" version of the window. Property bindings and event handlers will run, just like in the Client.

Some of Ignition's functionality will not work in Preview Mode, for example, the retarget and openWindowInstance scripting functions must be tested in a Client.


Preview Mode is useful for a quick check of the operation of a window, but it becomes cumbersome when trying to test a whole project. For that, we recommend having a launched Client up as well, and doing testing in the true Client. You can quickly launch a client in one of the following two launch modes via the Tools > Launch Project menu.


Tools Menu

The Tools Menu provides some tools to help you when creating projects. 

Each of the tools are described here.

FunctionDescription
Console

The Console is a dockable panel that you can open via Tools > Script Console menu or the Ctrl-Shift-C keyboard shortcut. The Console prints system messages that are coming from the designer. This can vary from simple info messages that show when things are loaded, to error messages when something goes wrong. The Console is also frequently used to test and debug Python scripts, as print statements on components that are run in the designer are printed here.

For example, by using the print function in your script, you can observe the inner workings of your script as it executes. If you executed the following script:

# A python script that demonstrates the print statement
 
print "Print me first"
x=10
z=2
print x, y, x/y
 
#Result looks like this:
#Print me first
#10 2 5
Image Management

The Image Manager is available from the Tools > Image Management menu. This tool is a drag-and-drop browser that helps manage the images that are stored on the Gateway. It is important to realize that these images are shared across all projects: they are not stored inside a project itself. Use the Image Management tool to do common tasks like uploading new images and creating folders. You can drag images and folders from your computer's desktop or hard drive into this window to easily upload new images to the Gateway.

You can also get to this tool by putting an Component Palette > Display > Image component on a window, and clicking the browse button on the image's Image Path property. See also Images (png, jpg, gif).

Script Console

Opens up the Script Console window. This is where you can test scripts out. See also Script Console.

Database Query Browser

Opens up the Database Query Browser panel, which allows you to run SQL queries against your database connections. See also: Database Query Browser

Translation Manager

Opens up the Translation Manager panel, which allows you to configure translations. See also Localization and Languages.

Symbol Factory

If you have the Symbol Factory module installed, you'll be able to open the Symbol Factory browser under the Tools menu in the Designer. You can browse through the symbols or use the convenient search function to find the symbol you need.

Once you find a symbol, you can drag-and-drop it into a window. Each symbol is dropped as a shape group. You will be able to un-group it or double-click into the group just as if you had drawn the symbol yourself using fundamental shapes. This means that you can alter the shape if you need to, or bind any colors inside the shape to a Tag to make the shape dynamic.

Cloud Templates BrowserOpens up the Cloud Templates Browser window, allowing you to import your own templates, as well as templates other users have previously uploaded.
Launch ProjectAllows you to launch the project directly from the Designer. You can either launch a staging or published windowed client, or a published full screen client.


Help Menu

The Help Menu provides online assistance when looking for information or troubleshooting an issue.

FunctionsDescription
HelpOpens up your web browser and takes you to this User Manual for quick reference.
Diagnostics

The Help menu in the Designer and the Vision Client has a Diagnostics window that contains a number of tabs each providing a useful troubleshooting feature. You can right-click on any of the tabs to show or hide the other tabs. For more information on these tabs and the troubleshooting features, go to Designer Diagnostics.

About Ignition DesignerProvides information about the Designer such as the versions of the modules, Java version, and Gateway IP Address that the Designer is using.



  • No labels